@webpack_ru
Webpack — русскоговорящее сообщество

Обсуждения webpack, лоадеров, плагинов и сборок Правила: http://bit.ly/our_etiquette См. также: @rollup_ru, @react_js, @vscode_ru, @macos_ru, @js_ru

974 members

Архив канала @webpack_ru 28 ноября 2017 г.

10:27:45 ДП
User 60122561
Выхожу к вам в интернеты с таким вопросом. Какие гайды из самых свежих и актуальных стоит глянуть по оптимизации вебпака? А то все очень медленно, а многие статейки протухли
10:46:34 ДП
User 30260375
User 60122561
Выхожу к вам в интернеты с таким вопросом. Какие гайды из самых свежих и актуальных стоит глянуть по оптимизации вебпака? А то все очень медленно, а многие статейки протухли
Видос с hollyjs
10:46:44 ДП
User 30260375
Ну или статью на хабре
10:55:58 ДП
User 60122561
User 30260375
Видос с hollyjs
Спасибки
10:57:12 ДП
User 60331718
User 30260375
Видос с hollyjs
Можно ссылку?
10:58:00 ДП
User 60122561
User 60331718
Можно ссылку?
https://habrahabr.ru/company/jugru/blog/342842/
habr.com/company/jugru/blog/342842
Webpack фактически стал стандартом для сборки крупных приложений на JS. Его используют практически все. Для разработчика webpack выглядит как магический черный...
04:25:05 ПП
User 150247499
Привет! Подскажите плс, как такое может быть, что в webpack dev server всё работает, а в продакшне выдает TypeError: Cannot read property 'exports' of undefined? Этот модуль я  импортирую через  import module from 'module', внутри него есть конструкция module.exports.installation = ...
05:03:49 ПП
User 134905826
User 150247499
Привет! Подскажите плс, как такое может быть, что в webpack dev server всё работает, а в продакшне выдает TypeError: Cannot read property 'exports' of undefined? Этот модуль я  импортирую через  import module from 'module', внутри него есть конструкция module.exports.installation = ...
module.exports должен транспилится в вебпаковские require-обвертки, babel стоит?
05:04:44 ПП
User 150247499
User 134905826
module.exports должен транспилится в вебпаковские require-обвертки, babel стоит?
ага, сейчас такой конфиг:

{
  "presets": [
   [ "env", {
    "modules": "commonjs"
  }
    ], "stage-2"
  ],
  "plugins": [
    "transform-runtime"
  ]
}
05:09:34 ПП
User 150247499
User 134905826
module.exports должен транспилится в вебпаковские require-обвертки, babel стоит?
причем в других зависимостях используются такие же конструкции и не ругалось, а добавил этот модуль и такая вот ошибка
11:24:17 ПП
User 113489745
Доклад шикарный