@webpack_ru
Webpack — русскоговорящее сообщество

Обсуждения webpack, лоадеров, плагинов и сборок Правила: http://bit.ly/our_etiquette См. также: @rollup_ru, @react_js, @vscode_ru, @macos_ru, @js_ru

974 members

Архив канала @webpack_ru 26 октября 2017 г.

02:43:12 ПП
User 246789071
привет!
02:43:17 ПП
User 246789071
подскажите пожалуйста
02:44:13 ПП
User 246789071
прикрутил вебпак3 в лендинг, все работало и работает хорошо. в хроме. Как то я решил открыть сафари, и там все упало. вот такая ошибочка:
02:44:14 ПП
02:45:58 ПП
User 246789071
можете пожалуйста подсказать, почему вебпак мог создать внутри себя const, и как это поправить
02:46:04 ПП
User 156780259
а код через babel прогнал?
02:46:13 ПП
02:46:19 ПП
User 246789071
причем еще прикол
02:46:19 ПП
02:46:28 ПП
User 246789071
оно появляется именно в режиме дев сервера
02:46:34 ПП
User 246789071
если просто сбилдить и открыть html файл ручками - все нормуль
02:47:49 ПП
User 246789071
вебпак конфиг у меня один и тот же и для разработки с вебпак дев сервером, и для обычного билда
02:48:45 ПП
User 246789071
в случае дев сервера просто дополняю конфиг вот этим и все :(
03:03:10 ПП
03:03:14 ПП
User 246789071
нашел в чем косяк
03:05:19 ПП
User 246789071
тем кто юзает webpack dev server - будьте внимательны, там примерно с версии 2.7.* они стали не превращать в своем вебпаковском генерируемом коде const в var, якобы щас все норм браузеры поддерживают const. откатился на версию 2.4.1 и все заработало
03:07:11 ПП
User 30260375
User 246789071
тем кто юзает webpack dev server - будьте внимательны, там примерно с версии 2.7.* они стали не превращать в своем вебпаковском генерируемом коде const в var, якобы щас все норм браузеры поддерживают const. откатился на версию 2.4.1 и все заработало
И правильно делают. Кому нужны эти ваши вар? Жду когда и в основном коде будет также
03:07:59 ПП
User 246789071
херово они делают. у меня не IE упал, а safari 9.1.2
03:11:04 ПП
User 147771380
User 246789071
херово они делают. у меня не IE упал, а safari 9.1.2
Этому браузеру скоро 6 лет
03:11:15 ПП
User 147771380
Как там в 2012?
03:11:52 ПП
User 246789071
нормуль, jade осваиваю
03:12:58 ПП
User 246789071
учитывая какой качественный софт apple стали выпускать, обновляться куда то желания нет
03:13:30 ПП
User 147771380
Ну значит, страдай и плюй на розроботчиков, которые плохо делают
03:13:42 ПП
User 147771380
Такая и есть психология необновляторов
03:14:25 ПП
User 246789071
так делали бы хорошо, как раньше, обновлялся бы
03:14:52 ПП
User 147771380
Так а почему "херово делают"? Дев сервер вебпака на фриков не рассчитан
03:17:14 ПП
User 246789071
я про apple софт, а не про разрабов вебпак дев сервера
03:17:22 ПП
User 147771380
User 246789071
херово они делают. у меня не IE упал, а safari 9.1.2
Пымц
03:17:53 ПП
User 147771380
У тебя упала древняя ненужная никому рухлядь, а ты негодуешь
03:18:22 ПП
User 147771380
Не расчитано, что адекватный разраб будет сидеть на таком
03:21:22 ПП
User 246789071
тебе с такими убеждениями о все самом новеньком и модненьком надо в европу топать, навстречу гомосне)
сомнеавюсь что в safari 10 есть что то, что прям киллер повод апгрейдиться. тем более что сам сафари мне апгрейдиться не предлагает, а качать самому что то мне лень
05:11:02 ПП
User 30260375
User 246789071
тебе с такими убеждениями о все самом новеньком и модненьком надо в европу топать, навстречу гомосне)
сомнеавюсь что в safari 10 есть что то, что прям киллер повод апгрейдиться. тем более что сам сафари мне апгрейдиться не предлагает, а качать самому что то мне лень
А лгбт то тебе чем не угодило?
05:12:30 ПП
User 30260375
Именно из-за таких ленивых умников, мы не можем юзать современные технологии в вебе. И это печально
05:23:26 ПП
User 52321317
User 246789071
тебе с такими убеждениями о все самом новеньком и модненьком надо в европу топать, навстречу гомосне)
сомнеавюсь что в safari 10 есть что то, что прям киллер повод апгрейдиться. тем более что сам сафари мне апгрейдиться не предлагает, а качать самому что то мне лень
будет работать дев-сервер. Чем не "киллер повод"?
05:29:24 ПП
User 147771380
User 246789071
тебе с такими убеждениями о все самом новеньком и модненьком надо в европу топать, навстречу гомосне)
сомнеавюсь что в safari 10 есть что то, что прям киллер повод апгрейдиться. тем более что сам сафари мне апгрейдиться не предлагает, а качать самому что то мне лень
2012, чувак. Это было очень давно.
А сколько ты ещё думаешь не обновляться. Никогда?
05:29:54 ПП
User 147771380
Будешь в 2020 тут тоже плеваться, что под твоё говно мамонта ничего не сделали?
05:30:30 ПП
User 147771380
Алсо, чем тебе Европа не угодила?)
05:31:22 ПП
User 30260375
User 147771380
Алсо, чем тебе Европа не угодила?)
Толерантным отношением к лгбт сообществу
05:32:02 ПП
User 147771380
User 30260375
Толерантным отношением к лгбт сообществу
Ну значит, с фриканутостью не прогадал
05:43:15 ПП
User 212795634
User 30260375
Толерантным отношением к лгбт сообществу
Значит ты латент
05:46:10 ПП
User 30260375
User 212795634
Значит ты латент
Да. Пойду в очко долбится.
05:47:01 ПП
User 52321317
Таки хватит срач разводить не по теме.