@webpack_ru
Webpack — русскоговорящее сообщество

Обсуждения webpack, лоадеров, плагинов и сборок Правила: http://bit.ly/our_etiquette См. также: @rollup_ru, @react_js, @vscode_ru, @macos_ru, @js_ru

974 members

Архив канала @webpack_ru 16 октября 2017 г.

09:52:08 ДП
User 111816761
как заставить девсервер выдавать больше логов? чтобы было видно куда отпроксирован запрос
10:03:27 ДП
11:05:54 ДП
User 111816761
это надо было смотреть доку  http-proxy-middleware. Его использует девсервер
09:22:15 ПП
09:22:16 ПП
User 122824793
коллеги, вебпак при сборке продакшн версии выдаёт дикую ошибку, совершенно не пойму куда копать
09:48:31 ПП
User 99532118
User 122824793
коллеги, вебпак при сборке продакшн версии выдаёт дикую ошибку, совершенно не пойму куда копать
stackowerflow вроде отвечает первой строкой, пробовали target ?
09:51:29 ПП
User 122824793
вот эта? https://stackoverflow.com/questions/40958895/webpack-uncaught-referenceerror-require-is-not-defined-after-removing-node-modu
stackoverflow.com/questions/40958895/webpack-uncaught-referenceerror-require-is-not-defined-after-removing-node-modu
bundle.js 2.83 kB 0 [emitted] main bundle.js.map 3.36 kB 0 [emitted] main When I add the code below with the custom externals, I can remove the node_modules from being directly inclu...
09:53:02 ПП
User 122824793
target не пробовал
09:53:46 ПП
User 99532118
во, я на эту наткнулся сразу https://stackoverflow.com/questions/44351310/require-is-not-defined-using-webpack-2
stackoverflow.com/questions/44351310/require-is-not-defined-using-webpack-2
I'm having problems with bundle my app using webpack, I've reading in the site similar problems though I've trying all the recommendations and I can't figure it out what's wrong. Everything bundle...
09:54:23 ПП
User 99532118
ещё много помогает искать прямо в тикетах на github, если остальные ответы не помогли
10:09:54 ПП
User 122824793
не помогает target
10:44:00 ПП
User 122824793
похоже вот такая херня:

Not all modules support module.noParse. They should not have a reference to require, define, or similar, as that leads to an Uncaught ReferenceError: require is not defined error.
10:45:10 ПП
User 122824793
мне в бандл почему-то прилетает ./node_modules/react-dom/cjs/react-dom.production.min.js"
10:53:36 ПП
User 99532118
это заранее собранный файл реакта и реакт-дом
10:54:00 ПП
User 99532118
они при боевой сборке должны как раз использоваться
10:54:08 ПП
User 99532118
CRA используете?
11:02:09 ПП
User 122824793
не, всё сам собрал
11:02:47 ПП
User 122824793
серверный рендеринг под реакт и всё такое. дев версия работает отлично. а вот в прод собирается с этой какашулей